Не могу обновится

Общие вопросы по операционным системам семейства Linux.
Bmax77
Мастер
Сообщения: 400
Зарегистрирован: 13 авг 2013, 11:05
Репутация: 39
Контактная информация:

Не могу обновится

Сообщение Bmax77 »

Код: Выделить всё

root@EMC26:~# apt-get upgrade
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install».
Пакеты, имеющие неудовлетворённые зависимости:
E: Неудовлетворённые зависимости. Попытайтесь использовать -f.
root@EMC26:~# apt-get -f install
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Пакеты, которые будут УДАЛЕНЫ:
  glx-alternative-mesa update-glx
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 2 пакетов, и 147 пакетов не обновлено.
не установлено до конца или удалено 2 пакетов.
После данной операции, объём занятого дискового пространства возрастёт на 0 B.
Хотите продолжить [Д/н]? y
dpkg: ошибка при обработке параметра glx-alternative-mesa (--remove):
 Пакет абсолютно неработоспособен — перед удалением его
 следует переустановить.
dpkg: ошибка при обработке параметра update-glx (--remove):
 Пакет абсолютно неработоспособен — перед удалением его
 следует переустановить.
При обработке следующих пакетов произошли ошибки:
 glx-alternative-mesa
 update-glx
E: Sub-process /usr/bin/dpkg returned an error code (1)
Давно уже живу с этой проблемой.
Подскажите как с этими пакетами разобраться, dpkg советует из переустановить но это не получается сделать.
Bmax77
Мастер
Сообщения: 400
Зарегистрирован: 13 авг 2013, 11:05
Репутация: 39
Контактная информация:

Re: Не могу обновится

Сообщение Bmax77 »

Какой то замкнутый круг.
Пытаюсь удалить glx-alternative-mesa ссылается на update-glx,
пытаюсь удалить update-glx ссылается на glx-alternative-mesa.
Аватара пользователя
Serg
Мастер
Сообщения: 21923
Зарегистрирован: 17 апр 2012, 14:58
Репутация: 5150
Заслуга: c781c134843e0c1a3de9
Настоящее имя: Сергей
Откуда: Москва
Контактная информация:

Re: Не могу обновится

Сообщение Serg »

Bmax77 писал(а):Давно уже живу с этой проблемой.
Где-то зависимости пакетов нарушены.
Bmax77 писал(а):Какой то замкнутый круг.
Удали оба одной командой (транзакцией).
Я не Христос, рыбу не раздаю, но могу научить, как сделать удочку...
Ответить

Вернуться в «Прочие вопросы Linux»